Menu
  |  Supported Web Browsers
Bookmark and Share

Supported Web Browsers

Many of the web based systems at Hood College only support web browsers that are compatible with TLS 1.2. The following is a list of some of the most commonly used web based systems that require TLS 1.2 compatible web browsers:

 
  • Self Service website
  • Blackboard website
  • Online Alumni Directory
  • Online Payments/Gifts websites
  • Reunion Weekend Registration Form
 

 

The following is a list of web browsers that are TLS 1.2 compatible:

 
  • Firefox - version 27 and above 
  • Google Android - version 5.0 and above 
  • Google Chrome - version 30 and above 
  • Microsoft Edge
  • Microsoft Internet Explorer - version 11 and above 
  • Opera - version 17 and above 
  • Safari - version 6 and above
 

 If you have any problems connecting to these websites, please contact the IT Helpdesk at 301-696-3922 or helpdesk@hood.edu.